XW6848+ settings when using two generators?

ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
I have been using my XW6848+ with a 6kw generator attached to Gen 1 and am using the Conext AGS.  Everything works great.  Now I have a second generator that I want to add to my system for redundancy.  It looks like I can attach it to the “Grid” breaker and rename it “Gen 2”.  I plan to run this generator manually if/when I have an issue with my main generator.  Anyone have any experience doing this with the XW6848+ or have any tips as I go forward?  Also my generator is a Type 9 - can someone guide me to the wiring schematic that describes how to wire the AGS wiring harness to the generator wiring harness?  Thanks in advance!
Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
«1

Comments

  • BB.BB. Super Moderators, Administrators Posts: 31,763 admin
    Just another thought... As I understand, the Grid and Gen AC inputs are physically the same, but the Grid and Gen defaults are different... I do not know if the AC1/Grid input can be fully programmed for generator support or not (others here can probably help with that).

    Another solution would be to put a manual or automatic transfer switch on the GEN/AC2 input to the two gensets. That way, there is no major reprogramming required. And if you have other "inverter/generator bypass" switches, their functions/usage remains unchanged.

    A very simple transfer switch is the relay type... "Off/Normal", your GEN1 supplies AC2 to the inverter... Fire up the second genset, and then GEN2 supplies AC2 input until GEN2 is shut down (and switches back to GEN1 (Grid) input. For example:

    https://www.solar-electric.com/pmts-50.html

    For me, "I like simple".

    -Bill
    Near San Francisco California: 3.5kWatt Grid Tied Solar power system+small backup genset
  • Ralph DayRalph Day Solar Expert Posts: 947 ✭✭✭✭
    I have my system set up with grid and 2 generators.  The 2 generators share one generator panel (select 10kw diesel or 2.8kw gas), and the other generator panel provides either utility or generator input (from 10kw or 2.8kw, previously selected).  Generator panels are handy, but bulky.

    If the 2.8kw is used (Yamaha 2800i) then parameters need to be changed.  

    Mate3 and VFXR3648A.  There's only one AC input, not sure if XW has gen and grid...my old Xantrex 4048 did.
  • ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
    Thanks for the input. Here’s my current game plan. The XW 6848+ has a “Grid” connection and. “Gen 1” connection. My plan is to connect my 6kw generator to the Grid connection and my 9kw generator to the Gen 1 connection. When the battery bank discharge parameters are met, the AGS will start the 9kw generator and charge the battery bank per the charging parameters set in the XW. If/when the 9kw generator fails, I will manually start the 6kw generator. The XW will sense grid power and will start charging the battery bank. The battery charger will be limited to 80% of the breaker size which is programmed in to the XW. I will monitor the battery bank charge level and I will shut the 6kw generator down once the desired Bulk and Absorb time parameters have been met.
    Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
  • Raj174Raj174 Solar Expert Posts: 795 ✭✭✭✭
    Looks like it could work with these configuration changes. This is a problem resolution from Shneiders support site.

    https://www.se.com/ca/en/faqs/FA312511/

    Rick
    4480W PV, MNE175DR-TR, MN Classic 150, Outback Radian GS4048A, Mate3, 51.2V 360AH nominal LiFePO4, Kohler Pro 5.2E genset.
  • ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
    Thanks for the FAQ link.  Since I will be running my backup generator manually - not using the AGS, I’m thinking that I can leave the configuration as is.  This will provide a safety backup if someone unfamiliar with the system were to try to put the backup generator on line while the main generator was running the AGS would take the main generator off line.
    Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
  • Dave AngeliniDave Angelini Solar Expert Posts: 5,952 ✭✭✭✭✭
    Any genset on AC1 is going to probably have to be an inverter based genset like EU7000i. The specs for AC1 even when widened are probably to tight for a generic genset.
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
    Thanks for the heads up on this Dave.  I’m using a Northernlights 6kw.  I’ll report back on how it does.  Not sure what my fall back plan will be at this point if it doesn’t work.
    Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
  • Dave AngeliniDave Angelini Solar Expert Posts: 5,952 ✭✭✭✭✭
    Buy a honda eu 7000i  :)  The economy needs you  ;)
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
    While Honda products are impressive - they are still “disposable” which rubs me the wrong way.  The Northernlights is a 20-30k hour machine, 1800 rpm diesel that burns .4gl/hr. Stay tuned...
    Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
  • Dave AngeliniDave Angelini Solar Expert Posts: 5,952 ✭✭✭✭✭
    To each his own. My Honda cars and ATV's just keep going and hold their value well. 

    A diesel is a good choice in cold climates but too much work if propane is available. I did get over 10,000 hours on my Isuzu spinning propellers. Had to triple filter and condition fuel to keep the algae from growing in the tropics. PITA but worth it.

    If the Northern lights will finely adjust frequency between load and no load it might work on AC!, might!
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
    In Alaska propane is nearly 50% more than diesel and can be challenging in the cold.  Propane has fewer BTU per gallon, which makes it even more expensive to use.  Got my fingers crossed on the Northernlights qualifying on AC1 - stay tuned.
    Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
  • RCinFLARCinFLA Solar Expert Posts: 1,351 ✭✭✭
    edited August 2020 #13
    I am missing the advantage of second gen tie into grid AC input.

    I have two gen setup, somewhat similar.  A large gen and a Yamaha EF3000.   This was a little more complicated with the 120vac Yamaha but idea is simlar.

    I run the Yamaha through two 2kVA isolation transformers.  This creates the 240vac and isolates the H-bridge inverter generator output. (not important to your situation)

    I bought a 30 amp DPDT relay and mounted it in a 7" x 9" electrical box that was made for cutoff switch.  Relay has 120vac coil and is wired so path to 30A port of big generator is normally closed requiring no coil power.  When I plug in Yamaha (separate outside wall port) it energizes coil of relay and flips over Gen port to Yamaha.

    So basically it is an A-B transfer switch that switches over whenever the 3kW Yamaha is run.  If your large gen is 6kW, a 30 amp DPDT relay will handle the current and they are relatively cheap and easy to find.  Relay coil only takes about 1 watt.  I also put 30 amp breakers on the relay output to inverter Gen input in a second small duel breaker stock box.  If you don't want to mess with connecing neutral at relay box then look for a 240vac coil relay.

    If you are not inclined to do the relay box build you can buy one of the 50A transfer switches for about $150.  I don't like them because they use solenoids that must be powered for either input and are cheaply built in my opinion.

    https://www.automationdirect.com/adc/shopping/catalog/relays_-z-_timers/electro-mechanical_relays/power_relays,_open-style,_40a_(ad-pr40_series)/ad-pr40-2c-240a

    https://www.automationdirect.com/adc/shopping/catalog/relays_-z-_timers/electro-mechanical_relays/power_relays,_open-style,_40a_(ad-pr40_series)/ad-pr40-2c-120a
  • Dave AngeliniDave Angelini Solar Expert Posts: 5,952 ✭✭✭✭✭
    Hi RC, nice to see you back! Where did you go? Off into the internet :)

    Doing what you are doing is one way. There are a few reasons to use AC1 offgrid. One is you have not set-up the AC2 correctly and have damaged the transfer relay on AC2. Even small loads banging those contacts when there is a disconnect will do cumulative damage to XW just like it would with the old SW's.

    There is another I can't remember right now. I would have to look it up.....

    Still staying tuned since March.....
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • RCinFLARCinFLA Solar Expert Posts: 1,351 ✭✭✭
    edited August 2020 #15
    I expected the AC1 grid port to be setup for grid criteria.

    Relay 'banging" only occurs when opening or closing under high current through contacts.  In the case of hybrid inverters it is much worse as it is normally because the grid went down with inverter pushing a near short circuit current through relay contacts on grid side when relay is being opened..

    The inverter must first establish lock on grid or gen before its connect relay closes so the external relay contact doesn't see 'make contact' high current.

    The one 'idiot proof' detail that is missing with the transfer relay is if you had the first gen running with inverter locked on and started second gen and plugged it in it would switch gens in mid stream at random phase to first gen phase lock on inverter.  That would not be good.  The inverter will drop the gen but maybe not before gen does a backflip.  That is one of the reasons I put the circuit breaker addition, just in case I went brain dead, which can happen after a hurricane.
  • Dave AngeliniDave Angelini Solar Expert Posts: 5,952 ✭✭✭✭✭
    My grid and gen relays on XW's have never been used here at the house. We don't have a genset or really ever have needed one. My clients get the warning on how to keep them from being an "idiot" as you say ;)  I had to borrow a genset to do the XWpro field testing here.

    AC1 is much tighter for frequency and voltage on XW and does not have the adjustment range of AC2, hence the problems both ways. I think old SW's were like this but I forget alot about those days.

    On XW it does not "bang" the relay on connect as it is a soft start. It is on disconnect the frying happens. XW ac2 will open in less than 10 msec under whatever load the gen is supplying. This is made worse by the 140adc charger on current xw's. People who do this get the "welded relay" fault. You can't get to many of those, I hear ;)
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • RCinFLARCinFLA Solar Expert Posts: 1,351 ✭✭✭
    My inverters run 24/7 as whole house UPS.  Probably average two or three momentary grid glitches per week due to Florida Flicker and Flash that causes inverters to momentarily dump grid connection..  Never have had a clock, DVR, or computer reset though.

    Knowing the beating the AC1 power relay gets I bought a spare about 15 years back.  My inverters have been running for 25 years with original relays (knock on wood).  This is likely only because they know I bought a replacement spare.  I did notice them on eBay for about $30 recently.
  • ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
    My need for having a second generator is purely for backup should my main 9kw generator go down.  I’m using the Schneider AGS to start my 9kw.  For auto start I have the generator wired with a 6 wire loom with a quick connect plug at the AGS.  My backup generator is a 6 kw, it also is wired with a 6 wire loom and quick connect plug.  If the 9kw goes down I manually switch the connectors at the AGS so that the AGS can control the 6kw when the batteries need charging. Since I am off grid I feel that having redundant generators is important.  Currently I have both generators wired to AC2 and switch breakers accordingly depending on which generator is plugged in to the AGS.  I may add a lockout breaker so that only one generator can feed AC2, but it’s probably overkill since the AGS can only control one generator at a time.
    Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
  • Dave AngeliniDave Angelini Solar Expert Posts: 5,952 ✭✭✭✭✭
    You can also network a 2nd AGS using a different address. That is how the folks north of 40 degrees do it.
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • mike95490mike95490 Solar Expert Posts: 9,292 ✭✭✭✭✭
    I have my generators wired to 240v electric stove outlets.  My inverter has a 240V stove cord on it, and that's how I connect to different generators.   Upon reflection, maybe I should have used RV campground connectors, but those are rare.
    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

  • Dave AngeliniDave Angelini Solar Expert Posts: 5,952 ✭✭✭✭✭
    Maybe a bad idea to use rV plugs, you will never get rid of your friends if they drive up to see you >:)
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
    Didn’t realize I could use two AGS on the same system.  I’ll have to look in to that thanks!  I need to update my firmware on the XW 6048, but have been nervous about doing it through the Gateway since the XW goes in to standby When updating the firmware.  Does this mean that the Gateway goes off line?  If so how does the firmware update get completed?
    Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
  • mike95490mike95490 Solar Expert Posts: 9,292 ✭✭✭✭✭
    ELYNN4 said:
    Didn’t realize I could use two AGS on the same system.  I’ll have to look in to that thanks!  I need to update my firmware on the XW 6048, but have been nervous about doing it through the Gateway since the XW goes in to standby When updating the firmware.  Does this mean that the Gateway goes off line?  If so how does the firmware update get completed?
    Very good.  I think the inverter continues to supply 24VDC to xanbus, but I use the wall wart plugged into eu2000 and power my router too, so it won't shut down.   Maybe Dave can verify if the Xanbus keeps power or not  ?
    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

  • Dave AngeliniDave Angelini Solar Expert Posts: 5,952 ✭✭✭✭✭
    edited August 2020 #24
    Since you need steady power to a modem for gateway to do inverter firmware I would not depend on xanbus power. Other devices like the mppt-80 also supply the 24 v xanbus supply.

    If you are offgrid, I do not think firmware will do anything for you on the old grey box xw 6048. Look at the release notes in the firmware packet.
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
    Thanks Dave - I’m trying to get my XW 6848 to play nicely with the Gateway.  I have the 9 kw generator now and I can’t get the XW to charge any more than 85 amps.  The option on the Gateway that allows it to charge up to 140 amps is grayed out.  I’ve heard folks describing how the can use the Gateway to ramp up their generators charging while it is running.  I was thinking that a firmware upgrade may allow me to do this.  Any other thoughts?  Thanks in advance.  I am worried about how to upgrade the firmware when the XW goes in to standby and I lose power to my router etc.  I would hate “brick” the XW!
    Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
  • Dave AngeliniDave Angelini Solar Expert Posts: 5,952 ✭✭✭✭✭
    First thing you have to do is make sure gateway is at 1.08. This will allow recovery of a bricked XW or other device. 

    Do what Mike said and run the house on genset by using AC bypass switching in PDP for inverter firmware. 

     As for your problem with the genny that does not sound right to me. What other loads are on? What is your input breaker setting on xw AC settings?

    Are you in the western smoke zone? Where are you BTW. See map, not many prescribed burns today, zero ;)





    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
    Thanks Dave, I’m in Alaska - we have a little haze here, nothing like the smoke you all are getting!  The loads when I’m charging are typically 200-300 watts.  My AC2 breaker setting on the Gateway is 50 amps.  My Gateway firmware is v1.06, so I will update it first.  I might run the Gateway off my Honda 2000, it’s a fair amount quieter than the diesel Genny.
    Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
  • Dave AngeliniDave Angelini Solar Expert Posts: 5,952 ✭✭✭✭✭
    Sorry I did not go back and look, must be nice up there. What part?

     A 50 amp setting should get you the full 140 amps of the charger if the gen can do it. You of course have the charge percentage at 100% right? 140 x 59 = 8,260. subtracting wiring and some power factor loss it might need 9kw or more from the genset.

     Run gateway and modem/computer off the secure power for firmware on XW, always !

     I think the gateway will stay powered from the inverter xanbus but the AC will go off and kill your modem/computer and
     cause a problem, or two...

     I use the config tool here or I switch AC bypass to a spare inverter power system when doing inverter firmware.

    Better map of the west. There are alot less fires today as many have grown into one big fire. Nice to be offgrid as Mike said. Less than an hour until happy hour. You have to wait a bit.




     
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
    Thanks Dave - we are in Talkeetna, Alaska which is North of Anchorage by a hundred miles or so.  Yes charging parameter is set to 100%.  The AC2 breaker is set to 50 amps.  Are there any other settings that might be holding it back? 
    Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
  • mike95490mike95490 Solar Expert Posts: 9,292 ✭✭✭✭✭
    Dial your charging back from 100%
    I always start charging at 5% and then ramp up manually as the generator warms up and can handle the load.  And at shutdown, I dial charging back to 5% and let the engine and alternator cool down for 2 minutes at light load.  If you have a lot of heat soaked in the alternator windings and cut off cooling air, it can cook itself in 20 minutes after you shut down
    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

  • ELYNN4ELYNN4 Registered Users Posts: 71 ✭✭
    Thanks Mike.  I do have the Gen warm up and cool down programmed in thru the Gateway.  It seems to work pretty well.  I have a remote radiator mounted in the garage of my house, which heats it nicely when the generator runs.  My generator house only gets up to 85 degrees.  I have 6 hours of absorb time so by the time the generator shuts down it isn’t doing a whole lot of work.  My generator runs at most every fourth day in the winter.  I’ve been averaging +/-250 hours of generator run time per year.
    Off Grid, 4.5KW array, 9&6KW Gens, 6848XW inverter, Midnite Classic 150, 2 strings - 48V - Trojan FLA L16 2V, located in Talkeetna, Alaska
Sign In or Register to comment.