Impressed with Outback

I've got a Flexmax 60 that's about a year old. It's screen is locked up and will not budge. I disconnected it's power source to "reboot" with no luck, so I called Outback and described the problem to them. No questions asked, they are just sending me a new one out today. I'm glad that I started my off grid system with the 15kw Perkins generator, as it's been great whenever I've had any kind of a problem.

Great customer service....I wish I had as good of experience with my Magnum Inverter. Oh well, life is great.

Comments

  • System2System2 Posts: 6,290 admin
    Re: Impressed with Outback

    you're in bagdad?
    How do you have internet?:confused:
  • blackswan555blackswan555 Solar Expert Posts: 246 ✭✭
    Re: Impressed with Outback

    The same question crossed my mind a few times, Till I saw a program mentioning it on UK TV a while back, Bagdad ( note the lack of an "H" ) AZ http://bagdad.arizona.com/ :D

    Tim
  • backroadbackroad Solar Expert Posts: 185 ✭✭
    Re: Impressed with Outback

    Verizon is a mghty powerful thing and yes it is the Az version of Bagdad.
  • keyturbocarskeyturbocars Solar Expert Posts: 375 ✭✭
    Re: Impressed with Outback

    What problems have you had with your Magnum 4448 inverter?

    That's the one that I have seriously considered buying.
  • backroadbackroad Solar Expert Posts: 185 ✭✭
    Re: Impressed with Outback

    It flat out quit invering. I had to pay about $50 to ship it to them after we diagnosed the problem over the phone. They said they could not find anything wrong with it and said I would have to also pay.for return shipping. I didn't feel very good about their customer service. When I got it back it worked fine. Very suspicious... i've had it for about two years and no other problems.
    :blush:
  • boBboB Solar Expert Posts: 1,007 ✭✭✭✭
    Re: Impressed with Outback
    backroad wrote: »
    It flat out quit invering. I had to pay about $50 to ship it to them after we diagnosed the problem over the phone. They said they could not find anything wrong with it and said I would have to also pay.for return shipping. I didn't feel very good about their customer service. When I got it back it worked fine. Very suspicious... i've had it for about two years and no other problems.
    :blush:

    Sounds like the inverter has or had an intermittent connection and fixed itself during shipping. They always seem to throw things around quite a bit.

    This is why I would give the unit a good (but safe) thump on the top and/or side to weed out a bad connection. If a unit cannot live through UPS or shipping, it has a problem (or the packing is badly designed)

    boB
  • mike95490mike95490 Solar Expert Posts: 9,571 ✭✭✭✭✭
    Re: Impressed with Outback

    Side note - re Thump.

    I opened my Tristar MPPT this weekend, to connect the RS232 cable (got to find a better way before I wear the cover threads out) and found in the base of the unit, about a 2" piece of solder ! WTF ! I pulled it out, everything was still working OK, but where the he$* did a hunk of solder come from ? All wire is copper, not tinned, must have been a factory leftover, that fell down from somewhere.
    So if I'd thump'ed it earlier, wonder where that would have settled ???
    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

Sign In or Register to comment.