Schneider Conext SCP Firmware Update - Power Readings Issue

hcosmehcosme Registered Users Posts: 10 ✭✭
I recently updated the firmware on my Schneider Conext SCP (SKU 865-1050-01 to the most recent firmware (Schneider Conext SCP2.04 APR 2018 to V2.05 JAN 2021) downloaded from the Schneider Electric website. I successfully uploaded the firmware via the Combox, but now when I use InsightCloud or login via a browser to my Combox, I no longer get any readings from the solar input (MPPT60/150) nor can see my actual load consumption. I also noticed that I can no longer see the solar power generation nor the current load on the SCP display 
Any suggestion on how I can get these readings back? I have already tried to reboot the system and I have even reinstalled the firmware to V2.04 and I can't resolve the issue. 


  • Dave AngeliniDave Angelini Solar Expert Posts: 6,138 ✭✭✭✭✭
    edited March 2021 #2
    Did you try a DC shutdown? Clear your web browser cache?
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
    E-mail [email protected]

  • hcosmehcosme Registered Users Posts: 10 ✭✭
    Thanks for the feedback, I tried to revive the SCP today (I cleared the laptop's cache and performed a DC shutdown as suggested, and I even disconnected the SCP from the Xanbus for awhile). I then powered the system back up, went into standby mode, then uploaded the firmware once again (first V2.04, then V2.05), but the problem was not resolved.  :'(
  • hcosmehcosme Registered Users Posts: 10 ✭✭
    The SCP screen and the Conext Combox screen do not display the SW4048, MPPT60 nor the System Load Data, only the

  • Dave AngeliniDave Angelini Solar Expert Posts: 6,138 ✭✭✭✭✭
    What else have you tried? Network cables or? 

    The SCP does not show solar input or loads without combox on xanbus? That would be really weird!
    What about devices, are they there?
    What else is in the system? Is this offgrid? Where are you?  More info will make this easier?

    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
    E-mail [email protected]

  • hcosmehcosme Registered Users Posts: 10 ✭✭
    I have the following five (5) Schneider Conext items in my off-grid setup here in Puerto Rico; all units are interconnected by Xanbus cables and the terminators are installed at each end of the Xanbus loop.
    SW4048 120/240
    MPPT 60/150
    Battery Monitor
    I have 2 banks of L16 Duracell Batteries (48V setup) 
    I checked the Xanbus cables and all are in perfect condition, no corrosion nor wear or tear. The Combox, SCP and the Battery Monitor are all installed inside an electrical cabinet and the Combox is connected to the internet via a ethernet cable to my router (see photo below)..
    This system had been up and running for two years now with no issues whatsoever until now.
    This issue started after I updated the SCP firmware as mentioned in the first post of this post string.
    All units are being detected by the Combox and there is no error (see photo below).
    I am thinking that perhaps the SCP failed when the firmware update was being performed. It hanged once the first time I updated the firmware; I powered the system off and on, then I managed to update the firmware as described in my posts above. No other firmware was updated (only the SCP)... perhaps it has "bricked"

  • Dave AngeliniDave Angelini Solar Expert Posts: 6,138 ✭✭✭✭✭
    edited March 2021 #7
    Thanks !  PR is split phase and that is why I wanted to know where. The SCP and combox do display the devices. They do not have any data. The temp data of -273 is a bit of a clue that data is not flowing. The temp on the bat mon is where the sensor is right?

    Also look in SCP system screen, scroll to the end and note any faults or warnings, one down from faults. Any on the day you did the firmware? I do not think you can say the SCP is bricked. Not sure that can happen either.

    I assume you have wiggled all of the network cables in case there is corrosion in PR. It would not be the first time they look good but  ;)

     I would disconnect all of the networking and just plug the SCP in with the mppt during daylight hours, then add the inverter, or do the opposite. When you powered down the DC, you shut down the solar in and let the system sit for 5 minutes or so. The DC on the CSW needs to be at zero volts DC.  

    Xanbus connection issues from Schneider below.

    Make sure Xanbus ports are being used throughout the system including the Terminator at each end of the daisy chain. Make sure to use known good Cat5e cables (standard Ethernet at least 6ft long). Try connecting one unit at a time while verifying unit appears on device list of SCP.

    Good Luck ! You need to isolate things. This can be a pain I know. Why did you do this if your are offgrid? 
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
    E-mail [email protected]

  • hcosmehcosme Registered Users Posts: 10 ✭✭
    Thanks for your feedback Dave. I'll look at all of this and get back to you once I have checked them all.
    The cables have all been checked, but I will recheck them. I have most of the instruments in a enclosure to avoid corrosion (only the MPPT and the Inverter are on the wall). I have two temp sensors installed in my system, one of them is connected to the SW4048, the other one is connected to the MPPT. I'm not sure if it is alright to have more than one connected on the same system, but they have been connected since the day I installed the system and have never caused a fault. 

  • Dave AngeliniDave Angelini Solar Expert Posts: 6,138 ✭✭✭✭✭
    The sensors are not the issue here, but you do only need one as the network should share data. 

    Since you know the battery monitor is getting data out to SCP, that is your starting point. Add one device at a time and leave combox for last. Everything is working right, powering loads? You are offgrid?  Need those answers manyana!  Buenos Suerte!
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
    E-mail [email protected]

  • hcosmehcosme Registered Users Posts: 10 ✭✭
    Gracias Dave!  I am connected to the grid (via a transfer switch) but I haven't drawn power from it since November. I connected the SW4048 to the grid via a 30A 240V breaker (instead of a generator) so I can run bypass/hybrid (self consumption) and/or disconnect the system if I have to perform maintenance or have an issue with the system. I have the option to switch to the grid when needed. I have this setup because i live just outside of the city and after Hurricane Maria we were without grid power for almost three months. I tend to run the system in an off grid mode most of the time (I'm on a hill just off the South coast where its very dry and sunny).
    Thanks again for you advise, I will check it out as soon as I can!
  • hcosmehcosme Registered Users Posts: 10 ✭✭
    Yesterday I performed the monthly maintenance (battery watering) of my solar generator batteries. When I was done and since the system was in standby mode, I verified the Xanbus cables. I did not find any corrosion on any of them nor on the sockets they were plugged into. I cleaned the connection ends with contact cleaner before reinstalling to make sure that they were free of dust or corrosion. Since I had disconnected all the cables, I performed a rerun of the order of the cables; they now are daisy-chained in the following order: (TERM)-SW4048-MPPT60-BATTMON-COMBOX-SCP-(TERM). I then reinstalled everything, powered up and I continue to have the same issue.
    Question: I have a few cables that were custom made (shorter than 6ft) because  the enclosure I have is quite small and I wanted to keep it as uncluttered as possible. I did this because I had read online that cable length does not affect the cables' operation; but others  say that the cables should be 6' long (Dave also mentioned this, see above). Does anyone have any negative experiences using shorter cables for Xanbus? Do all Xanbus cables have to be of the same length? Note: the short custom cables were installed when I first installed my system and I had never had an issue with them until now. 
    I plan on isolating the Xanbus units and cables one at a time as Dave suggested (see above) later this week hoping to isolate the defective cable or unit. I will post the results of this testing. I also ordered an inexpensive cable tester as I currently don't have one. Hopefully I can finally resolve this issue one way or another.
  • jtdiesel65jtdiesel65 Solar Expert Posts: 241 ✭✭✭
    edited April 2021 #12
    I don't have a mppt but had a similar display problems when I used the conext battery monitor with the combox. Fixed itself when I removed the battery monitor out of the xanbus daisy chain. IIRC I power cycled the combox too.
  • hcosmehcosme Registered Users Posts: 10 ✭✭
    I still have not been able to verify the cables nor isolate the components of my system, but I intend to do so soon and I will post the results.  I am still waiting to receive a cable tester I purchased online, and it seems to have gotten lost on its way here  :(
  • Dave AngeliniDave Angelini Solar Expert Posts: 6,138 ✭✭✭✭✭
    The odds are against a cable being the problem since this worked before. Isolate the devices and power cycle as discussed.
    The mean season is coming, better get this thing working! Good Luck!
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
    E-mail [email protected]

  • RavemindRavemind Registered Users Posts: 12 ✭✭
    I am experiencing the same thing. Updated the SCP firmware from v1.. to v2 and now it's useless. most options are unavailable. Only battery voltage is visible, sometimes.
    I have a combox and insight home. both are receiving very limited info. 

    It's been a long time since the system was commissioned,
    Main property - 4.5 kW panels into 2 x Schneider MPPT60 150v charge controllers | Schneider Conext SW4024 Hybrid inverter | 30 kWh of Lithium Batteries 24V - Water pumping - Grundfos SQflex | 1000w solar panels | Midnite Solar theKid | 48v Lithium battery |
Sign In or Register to comment.