Help with diagnostics getting

skipperfskipperf Registered Users Posts: 12 ✭✭
Living off grid in Mexico dealing with a Xantrex XW6048 and Generac 20Kw backup generator. The system is about 6 years old. If it has been a few days since the gen has run, the XW sees and accepts current from gen. If gen is needed multiple times in same day, the inverter sees the gen running (charge light on inverter panel blinks) but doesn't accept any charge current after the first time. We have verified 240 volts from the Gen, through the ATS, into the lugs on the main control board at the inverter. We have raised the rebulk voltage to ensure that the set point is above the battery voltage. Any other diagnostics that can be offered to help us understand what has failed?

Looking forward to any responses.
Skipper Flowers
Quintana Roo, Mx.

Comments

  • mike95490mike95490 Solar Expert Posts: 8,434 ✭✭✭✭✭
    You need to read the glossary in the back of the manual, and put settings back to factory.  Then you can start troubleshooting.
    What are you adjusting things with, SCP or Combox ?
    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

  • skipperfskipperf Registered Users Posts: 12 ✭✭
    mike95490 said:
    You need to read the glossary in the back of the manual, and put settings back to factory.  Then you can start troubleshooting.
    What are you adjusting things with, SCP or Combox ?
    Yes, using the SCP. I am trying to help a neighbor. He had a local Gen tech out but couldn't identify the cause. Schiender tech on phone said maybe was waveform from gen and to confirm with O'scope. There is not an O'scope within 500 miles from here.
  • BB.BB. Super Moderators, Administrators Posts: 29,644 admin
    Confirm frequency, and try a 100 Watt filament lamp or small electric heater on the genset ac output.

    A small load has been found to stabilize generator output for some folks.

    -Bill
    Near San Francisco California: 3.5kWatt Grid Tied Solar power system+small backup genset
  • skipperfskipperf Registered Users Posts: 12 ✭✭
    BB. said:
    Confirm frequency, and try a 100 Watt filament lamp or small electric heater on the genset ac output.

    A small load has been found to stabilize generator output for some folks.

    -Bill
    Bill, The freq was confirmed at 60hz 240v at the main board of the inverter. Would I put the load in series and would it go before or after the ATS? I don't believe the gen has a service convenience outlet, only the cables from the breaker on the gen to the ATS in the inverter. I will go over and check tomorrow.
  • mike95490mike95490 Solar Expert Posts: 8,434 ✭✭✭✭✭
    sometimes, and unloaded generator has some extra high voltage spikes that prevent an inverter/charger from syncing to it,  So, loading it somewhat with a moderate load like a 250W heat lamp or big halogen (no energy saver LED's need apply) worklight, will let the charger sync and utilize it. 
    There are also settings for the AC2 (Genset) input, to widen the Fq and Voltage acceptance window so it's more likely to sync.
    And be sure to record the final settings for future reference.
    With recent SCP firmware, you should be able to really widen the AC2 settings:

    XW.CFG_AC1_LOW_V = 106000
    XW.CFG_AC2_LOW_V = 88100
    XW.CFG_AC1_HIGH_V = 132000
    XW.CFG_AC2_HIGH_V = 140000
    XW.CFG_AC1_LOW_F = 5500
    XW.CFG_AC2_LOW_F = 5000
    XW.CFG_AC1_HIGH_F = 6500
    XW.CFG_AC2_HIGH_F = 6900


    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

  • skipperfskipperf Registered Users Posts: 12 ✭✭
    mike95490, can the Xantrex SCP firmware be updated without using their special tool? If older firmware would the values suggested above be the same? Can you suggest a good place to apply a load to gen as there is no plug in.

    Thanks for the replies so far,
    Skipper

  • BB.BB. Super Moderators, Administrators Posts: 29,644 admin
    The lamp/heater load is just across the genset output. As Mike says, it is to help stabilize the output wave form with a "simple" resistive load.

    -Bill
    Near San Francisco California: 3.5kWatt Grid Tied Solar power system+small backup genset
  • mike95490mike95490 Solar Expert Posts: 8,434 ✭✭✭✭✭
    Only the Combox, Gateway (discontinued) or the dealers loaner Implanter can update firmware on XW gear.

    The generator should be connected to both AC2 phases.   It would be unusual for a generator to not have a set of outlets on the control panel, unless it was part of a industrial backup plant.  Generac is not high end stuff, and I'd expect to see some outlets in addition to the hard wire cable.   But if not, it should be a simple task to have an electrician wire in a couple of utility outlets and a breaker to the main feed.  Manual shows there is an outlet:

    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

  • Dave AngeliniDave Angelini Solar Expert Posts: 4,780 ✭✭✭✭✭
    skipperf said:
    mike95490, can the Xantrex SCP firmware be updated without using their special tool? If older firmware would the values suggested above be the same? Can you suggest a good place to apply a load to gen as there is no plug in.

    Thanks for the replies so far,
    Skipper

    The SCP is only going to show the XW inverter value choices and is not what you would want to update> The inverter did have updates to widen the value choices in AC2 if this is an older XW. Be sure you really have widened the AC2 choices to max. I have been flown to a help a client make changes and they were on the AC1 screen by mistake. Kind of expensive but fun for me....
    The SCP firmware changes were for the HVmppt harvest screen and will not help you. Another firmware version for the SCP added the new SW and XW+ updates that also will not help you.

    An inexpensive generator is almost always going to be a pain with a Hybrid Inverter. Buy more solar and get better and managing loads and conserving during poor solar weather. An alternative generator is the Honda EU7000i. Works great with hybrids from Outback and Schneider. What are you Skipper of BTW?
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • new2PVnew2PV Solar Expert Posts: 305 ✭✭
    The Eu7000 series genterator works great with XW inverters. I would suggest selling the generac, as  XW is very sensitive to a clean signal, which your not seeing.
    XW6848 inverter with 2 X mppt 60 150 CC , with Canadian solar 260Watt panels 2 x 3.5 kw array
  • mike95490mike95490 Solar Expert Posts: 8,434 ✭✭✭✭✭
    edited November 2016 #12
    new2PV said:
    The Eu7000 series genterator works great with XW inverters. I would suggest selling the generac, as  XW is very sensitive to a clean signal, which your not seeing.
    Shut your mouth before my rig hears that,   My XW works great with my listeroid @ 650 RPM with 5 hz power stroke wobble. 
    http://lister-engine.com/lef/index.php?topic=208.0
    But if you connect the generator to AC2 (which has looser specs for generator RPM and voltages than the Grid AC1) it should be OK.

    XW.CFG_AC1_LOW_V = 106000
    XW.CFG_AC2_LOW_V = 88100
    XW.CFG_AC1_HIGH_V = 132000
    XW.CFG_AC2_HIGH_V = 140000
    XW.CFG_CHG_BLOCK_START = 0
    XW.CFG_CHG_BLOCK_END = 0
    XW.CFG_LOAD_SHAVE_END = 0
    XW.CFG_LOAD_SHAVE_START = 0
    XW.CFG_AC1_LOW_F = 5500
    XW.CFG_AC2_LOW_F = 5000
    XW.CFG_AC1_HIGH_F = 6500
    XW.CFG_AC2_HIGH_F = 6900


    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

  • skipperfskipperf Registered Users Posts: 12 ✭✭
    Update: Issue may be solved. I was looking through the manual and in the exploded view and parts list, I saw a bridge diode listed. Thinking back 30+ years ago from electronics school I remember bridge rectifiers being used to lower voltage or change AC to DC. Knowing that rectifier circuits are made up of diodes, took a guess and decided that the listing of bridge diode may be a rectifier circuit. My neighbor had family from the US coming for a visit so he ordered one. It was less than 20$ so cheap enough to take a guess on. The part arrived and was replaced. The XW inverter saw current from the gen on 4 consecutive tries. I told my neighbor that I would not be convinced of a fix until a few weeks of consistent function from the gen, but looks good today.

    Dave, Skipper Lee is my middle name. My first name was from my father's brother who was killed in Korea before I was born. Lee is my mothers maiden name. Mom says she gave me an offbeat middle name so I would have a name of my own instead of being just a namesake.
  • Dave AngeliniDave Angelini Solar Expert Posts: 4,780 ✭✭✭✭✭
    Thanks, I was asking because many of my sailing buddies ended up near you. Good fix, I hope....
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • new2PVnew2PV Solar Expert Posts: 305 ✭✭
    I knew it had to do something with a distorted signal. Congrats on getting it fixed!
    XW6848 inverter with 2 X mppt 60 150 CC , with Canadian solar 260Watt panels 2 x 3.5 kw array
Sign In or Register to comment.