My Well pump did not turn on....what next

SystemSystem Posts: 2,511 admin
I have a shallow well with a sun pump, its been very reliable. I only use it every two to three months. only for about the last 3 years.
When I get to the Cabin this weekend it did not come on after turning on the controller, I checked the voltage at the controller and had 40+ input and 28+ output trying to start the pump. The water is kind of minerally (stains the toilets and leaves orange residue(Fe) in my tank)

What should I do next? Will a pump corrode or lock itself up?, I had to do some revisions to the piping and wiring for easier servicing because I didnt really plan on having to pull the pump, so I left it in the well.

Comments

  • mike95490mike95490 Solar Expert Posts: 9,011 ✭✭✭✭✭
    Re: My Well pump did not turn on....what next

    Can you tell if it is trying to draw any power from the batteries ? Monitor battery voltage, flip on switch, does voltage sag, or drop a few hundredths of a volt ? (use a digital meter)
    I suppose all sorts of things can happen to a seldom used pump, I guess we'll hear back from you as to what it was.
    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

  • System2System2 Posts: 6,290 admin
    Re: My Well pump did not turn on....what next

    No batteries, panels through controller to pump, 40V from panels, 28V output to pump, havent tried to check current.
Sign In or Register to comment.