MPPT 60 Firmware Upgrade Failed

b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
Hi, i have several MPPT 60 at version 1.05. Have been tried to do a firmware update for about 3 or more years, result is always "Firmware Upgrade Failed". 
A year ago, replaced the Lead Acid Batteries for two Discover AES. Since then I have the problem that the MPPT 60, auto reset every other month, and stop producing because setup conflict, all have the name MPPT 60 00. System stop production for a couple of days or weeks until I notice and go to Multi Unit Config to rename them MPPT 60 01 and MPPT 60 02.
Then the problems comes back after 3 or 4 months. I have call Schneider, they said to call Discover, I have call Discover, they said I must update the MPPT to the latest Firmware, but I cant.
I have tried using the Conext Gateway and the Config Tool. Not luck at all. Always get "Firmware Upgrade Failed' error. 
How I can solve this problem?, Schneider and Discover Customer Service have no clue!
Please help!!!!

Comments

  • b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
  • Dave AngeliniDave Angelini Solar Expert Posts: 6,226 ✭✭✭✭✭
    List exactly what you have done ! Basic things would be shutting down DC in/out for 5 minutes first. Are there any faults or warnings logged in the mppt's?  Have you tried restoring defaults on mppts? Have you tried just doing one at a time?

    Have they been exposed to lightning? Have SPD's? 

     Sounds like you know the 2 devices must have a different number for the network to see them. Maybe the non volatile memory is defective on one or more?

    One fix would be to get another new or borrowed mppt and copy it's firmware into your 2 units.

    You are sure that the new firmware is good and not corrupted?

    Good Luck!
    "we go where power lines don't" Sierra Nevada mountain area
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
    Hi Dave
    I have tried one at a time, two at a time. Turning one off (PV and Bat breakers), disconnecting Xambus cables and connecting the config tool directly to just one MPPT, connecting just the inverter and one MPPT to the Gateway, reset everything to factory default, re boot, etc...
    i have seen this in other installations with lead acid, called to customer support, no help at all.
    But, the thing is that with Discover AES in Close Loop, I need all devices in the latest firmware for the system as a whole to work properly. 
    I have try to do firmware upgrade to 1.06, 1.08 and 1.09, same failure with all versions. 

    How can I get the firmware of a new MPPT 60 and copy its firmware to these olds MPPT 60s?
  • Dave AngeliniDave Angelini Solar Expert Posts: 6,226 ✭✭✭✭✭
    edited August 7 #5
    There is a menu choice to copy firmware from the other mppt in the SCP. I would assume you have a SCP?

    I do not understand what you expect Schneider to do? You probably have at least one unit bad, an old one, that is long out of warranty.

    I have not seen or heard of this problem BTW. Unless you are doing something very wrong here (network not terminated etc.), it is time to get a new one and eliminate this to solve the problem.    Good Luck.
    "we go where power lines don't" Sierra Nevada mountain area
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
    Hi Dave, this particular units are in my house, I saw the issue where they still under warranty, but, with a 35 kwh lead acid battery, i dint have the need for new firmware. Once I replace the lead/acid for Discover AES Lithium, the issue started, MPPTs still where under warranty, but customer service told me the "auto reset to factory every 3 to 4 month whats caused by Discover, si I had to work with them", so I spend a lot of calls with Discover about the issue, they always said the problem is because the MPPTs dont have the last firmware... 
    suddenly, the warranty time pass away...
    Schneider never was able to help
    Discover never was able to help
    because it was my house, I dont mind play with my system every other month...
    the big problem I have now is, I had a lot of customer replaced old lead/acid with Discover AES Lithium batteries, and now they are having the same issue, and I had to go in person every 3 to 4 month to reset and reprogram, and thats been a big pain for me and the customers are not happy at all. 
    I can in my house install new MPPTs by my cost, but, what about the clients?? 
    right now the MPPTs are not under warranty, but that should not stop Schneider in to making some reset firmware or something in order to install the latest firmware to MPPTs that still where under warranty a couple of months ago 
  • Dave AngeliniDave Angelini Solar Expert Posts: 6,226 ✭✭✭✭✭
    edited August 9 #7
    I still am not getting this!     How can all of these mppt-60-150's not load firmware? The configuration tool and the Gateway not working to load firmware??? Loading firmware has nothing to do with Discover AES. It may cause the reset, but you need current firmware.

    If you send me the Schneider Case number or numbers, I will have a friend at Schneider look them up. Where are you please?

    Also, if you want my help, you have to answer all of my questions in my last post.
    "we go where power lines don't" Sierra Nevada mountain area
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • PhotowhitPhotowhit Solar Expert Posts: 5,909 ✭✭✭✭✭
    If you send me the Schneider Case number or numbers, I will have a friend at Schneider look them up. Where are you please?

    Also, if you want my help, you have to answer all of my questions in my last post.
    Dave is an experienced installer who also monitors over 100 systems, most(all?) of which he's installed.

    It's quality help!
    Home system 4000 watt (Evergreen) array standing, with 2 Midnite Classic Lites,  Midnite E-panel, Magnum MS4024, Prosine 1800(now backup) and Exeltech 1100(former backup...lol), 660 ah 24v Forklift battery(now 10 years old). Off grid for 20 years (if I include 8 months on a bicycle).
    - Assorted other systems, pieces and to many panels in the closet to not do more projects.
  • b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
    HI Dave;

    This is not an isolated problem, because I have at least 3 clients that MPPTs firmware is at 1.05 and cant update to the latest one. 
    All of them with Discover AES. Discover battery is not causing the upgrade problem, but because of the reset every 3 to 4 months, we where in the need to make the upgrade and wasn't able to do it.
    methods tried:
    1. physically connecting only one MPPT, to power and to xambus
    2. using the Gateway
    3. using the config tool
    4. rename the last firmware to the name of a 1.05 firmware.
    5. I  cant be sure if turned them off for 5 minutes... but I have disconnected lets said the MPPT-01 to work with the MPPT-02 and vice versa...  just can assure if the unit where off for less or more than 5 minutes, have to try taking the time. 
    6. no fault or warnings listed 
    7. cant know if they where exposed to lighting, nothing its burn and they are producing energy as they should
    8. I have Midnight lighting arrestors
    9. not sure if the new firmware is corrupted, but I have tried several versions, always same result as the image posted. 
    10. dont know how to transfer firmware from one installed mppt60 to another one installed
    11. I dont have the case number as I never write them... that's my bad...   I just call, if dont receive help, then I try to solve by myself...  99% with some time I have resolve all issues...    
    12. I am from Puerto Rico

    Units have manufactured date 2015 or before. I start using Discover batteries at 2017, so units where at warranty when the issue start, just I thought with the calls made, Schneider will take notes and make the next firmware load ok those old units, or send an email with step by steps or trouble shooting guide, but never happened. time pass and units are no more under warranty. Never pass true my mind to ask for a replace, as the customer representatives never present that as a solution neither 


  • Dave AngeliniDave Angelini Solar Expert Posts: 6,226 ✭✭✭✭✭
    Can you upgrade successfully any firmware? Like XW or other xanbus devices ? 
    Can you use the config tool to revert back to an older version of firmware?


    "we go where power lines don't" Sierra Nevada mountain area
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
    Yes, in same 3 houses, I am able to make firmware updates to the Insights / Gateways, XW, even other MPPT 60s installed in same houses... 
    i am going to try the 5 minutes off now. 

    about using config tool to revert back an older version of firmware, have not try it. But I dont have nay previous firmware, they were gone with my previous laptop.
    do I need to have in my laptop a previous firmware in order to revert back ?
  • b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
    i only have in this laptop firmware versions 1.06, 1.08 and 1.09
    can you send me by email the 1.04 and 1.07? 
    [email protected]

  • b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
    So I am at my house, I have a XWPro, 2 MPPT60s, 2 Discover AES
    I turn off 60 and 80 amp breakers of both Charge Controllers, wait 10 minutes
    Connect to the Gateway
    turn on MPPT60 01 (kept MPPT60 02 off)
    Try to lead 1.06 firmware, this is what happened



    after a couple of seconds, I got this error



  • b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
    turned MPPT60 01 off, wait more than 5 minutes, turned it on, tried to install firmware 1.09, the same result


  • b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
    I did all the clear and reset that can be done using the Gateway, turned the MPPT60 01 off for 5 minutes, did reset again, put t in stand by, disconnected the Discover AES Battery's form the xambus network... still got the same result. it always stay at 5% then the error 
  • b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
    This is my house installation 
  • Dave AngeliniDave Angelini Solar Expert Posts: 6,226 ✭✭✭✭✭
    edited August 14 #17
    Nice install BTW! 

    When you are installing firmware, the mppt-60 is on-line right?  Your screen shows it offline!

    The config tool needs to have a the previous firmware stored on the PC. This is not your problem. I will read your posts again later, too close to happy hour :)

    link to down load below. the file is too large to email BTW.

    https://solar.se.com/us/en/product/conext-mppt-60-150-solar-pv-charge-controller-2/#downloads

    FW202007_Conext-MPPT-60-150-Firmware-V1.09-BN0001
    "we go where power lines don't" Sierra Nevada mountain area
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • b. ecologìcAllb. ecologìcAll Registered Users Posts: 41 ✭✭✭
    the MPPTs are online when start the firmware update. it stay a while at 5%, then there is an error message and it goes off line. 
    I turn the brakers off and on, and it start working like nothing 

    the link you gave me is for the latest firmware. I have it.  I was willing to have the 1.04, maybe 1.05 and 1.06 in case the one I have are bad
  • Dave AngeliniDave Angelini Solar Expert Posts: 6,226 ✭✭✭✭✭
    I think you need to call Schneider and this time get a case number.

    Firmware rarely goes bad and this is a mature product.

    When you download, each firmware release has release notes. There is nothing in them about your issue but you should see what Schneider says. Once you have a case number, and it is not resolved, I can inquire. This is gratis for the PR, one of my favorite sailing places, back in the day.  I do this as a business!

    One of the previous builds 1.08 lists the ability to enable or disable the charger. This is important for the BMS in the AES battery.

    Other builds below may also be causing this.  See below.  Before you call Schneider, look for and list all historical faults, warnings, and events.

    One thing I must tell you is this system works very well for me. Probably 40 or more out there sailing smoothly!  Good Luck !





    "we go where power lines don't" Sierra Nevada mountain area
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

Sign In or Register to comment.