Schneider XW+ inverter shut down while uploading firmware

eliueliu Registered Users Posts: 1
When I was loading the must recent firmware into Schneider XW+ 6848 NA, the inverter just shut down and it can not  turn on. The firmware information at the SCP is empty.

Comments

  • Dave AngeliniDave Angelini Solar Expert Posts: 4,842 ✭✭✭✭✭
    If you have warranty you are going to have to get help from Schneider. Somehow you have "bricked" the unit.
    What device did you use to upload firmware? There are 3 choices. 
    There is a chance you can revert back depending on the device you used.
    Good Luck!
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • GulloGullo Registered Users Posts: 14 ✭✭

    Eliu 

    There are a couple of possibilities here. When a firmware upgrade fails, and the unit goes black (this is very common when users upgrade firmware without putting other devices into standby), and it disappears from xanbus, it is often still available. Depending upon how you upgraded, it could be easy.... If you used the conext combox, it's pretty simple. If you used the Gateway or the Config tool, it gets more complicated.

    Did you use the Combox? If so, the inverter is still available in bootloader mode. You can fix it yourself - easily. I'm a long-time end user of the XW equipment, and I've had firmware upgrades fail in the past. The process is pretty simple.

    If you used one of the other devices, you will have to go to the Schneider support website, and submit a service request. They will respond.

  • alvenegasalvenegas Registered Users Posts: 7 ✭✭
    Hello, I happen to fall in the same problem and I don't see a bootloader included in the firmware zip file I downloaded from the website.  I followed the instructions on the Solar SE PDF file and first did the upgrade of firmware to the SCP and went without a problem.  Then moved to do the upgrade to the XW+, then it shutdown.  No way to turn it on.  Any help is greatly appreciated!

    Thanks.
  • Dave AngeliniDave Angelini Solar Expert Posts: 4,842 ✭✭✭✭✭
    As above you probably are going to need to contact Schneider. As above if you really expect someone here to help you need to list the upload device.

    Here is the link to the form you will need to fill out for support. 
    https://solar.schneider-electric.com/tech-support/netsuite/

    Just a note to anyone else reading this, there is very little reason in an offgrid system to upgrade firmware on an XW+. You could ask first!

    If you are grid-tied you should first "experiment" on other devices in your system before you do an inverter. An inverter is the heart of the system and needs a qualified individual to perform firmware update. Become qualified by doing firmware on another device besides XW+.
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • alvenegasalvenegas Registered Users Posts: 7 ✭✭
    Yeah, too late for me.  I would have not bother doing the upgrade if it weren't for the fact that the new firmware corrected block setting times, which I needed.  And, I did experiment upgrading the SCP first, which worked fine, that's why I felt confident it would work.  Finally, the instructions for upgrading firmware is nothing an expert experience is required.  I have done hundreds of firmware upgrades in diverse devices and never I have had this troublesome experience.  The only pop up warning I received before pressing the OK button to begin the upgrade was that the system was to enter Stand By mode, that the device should let alone to upgrade and that it would come back to life.  Well, that was not as expected, since as soon I hit the button, the XW+ went dead.  I waited and waited and nothing happened.
    Yes, it is great that we are discussing this now, but came too late.  By the time you are looking at this trouble title in google, you already have pressed the button. 
    It is been 14 hrs since my XW+ went dead and I still have had no reply from the customer support website ticket order I placed then.  Hopefully I can bring my XW+ back to life....I'll keep updating.  Thanks for replying.
  • alvenegasalvenegas Registered Users Posts: 7 ✭✭
    By the way, my XW+ 6848 120/240V had FW2.03, and I was upgrading to the latest (2.07).  The name of the xf0 file is: 865-6848-2.02_07_00.BN0004.xf0
    There was no bootloader file in the zip file.


  • Dave AngeliniDave Angelini Solar Expert Posts: 4,842 ✭✭✭✭✭
    You did not list which device you used for updating firmware. There are 3 different ones BTW. Again asking this?

    Did you lose power to the modem?

    Schneider can take some time with this and you are not the first one to have this problem. We have gone thru this many times here, long before your time I am sorry to say.

     Plenty with Outback Power systems also.
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • alvenegasalvenegas Registered Users Posts: 7 ✭✭
    Sorry, I used a ComBox to send the upgrade to the XW+.   Did I loose power to the modem....good question and thanks for bringing me this to my attention, it may have been a cause, however, No, i did not loose power to the modem because it has a UPS.  When I did the upgrade to the SCP I still had the loads on, but then I switched to my failover setting, which is a transfer switch bypassing the Inverter, just in case these problems occurred.  So, after the SCP upgrade, the system came back online no problem.  Then, I connected to the combox, uploaded the firmware xf0 file to the XW via the combox, and then applied the upgrade.  So, by this time, the entire house was running on grid power, so there was no interruption of power to the modem, nor any of the switches.
  • Dave AngeliniDave Angelini Solar Expert Posts: 4,842 ✭✭✭✭✭
    The combox losing power from XW during firmware is a known cause of bricking the inverter.

     Sorry but you need Schneider as I do not have time to walk thru this and I do not want to be responsible if you have warranty. Combox gets power from XW+ xanbus and the wall wart. Any interruption can do this during firmware update, hence your standby warning.

    The one thing you can try is looking in firmware file for a previous file (the old xw xfo) and revert to it.

    Offgrid folks run a genset or a second inverter/charger to avoid this. A learning experience good luck!
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

  • alvenegasalvenegas Registered Users Posts: 7 ✭✭
    Thank you, but the Combox is connected to UPS too.  It draws power from the Xanbus and the power supply connected
    to the UPS.  It shouldn't be that the cause.  But thanks for the help.
  • mike95490mike95490 Solar Expert Posts: 8,470 ✭✭✭✭✭
    i use a car battery jumper pack to power my combx because the XW does shut down during upgrade and the combox looses power.
    It's the subtle details.
    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

  • alvenegasalvenegas Registered Users Posts: 7 ✭✭
    Okay, so my XW+ came back to life.  I turned off for a couple of hours both breakers in the MiniPDP so that I would let the inverter to do a discharge of all capacitors.  I then powered it back and saw the display flashing momentarily, but then went dark again.  I verify in the SCP and saw that it recognized a Xanbus device as INV/CHG, which had features that could not be edited.  However, in the Combox, no INV/CHG was present, only my two MPPT60's and the SCP.  By serendipity I decided to see the Upload section of the Combox, and clicked on the drop-down menu.  To my surprise I saw the INV/CHG device there with the words "bootloader".  I immediately chose it and then on the firmware file section the 2.07 xf0 file showed up...because the Combox may have kept it saved somewhere.  I then proceeded to install it to see what would happen and it gracefully started to process the firmware upgrade.  It went all the way to 100% and voilá, the display on the XW+ came back to life, doing the 5 minute countdown.  I was so happy!
    So, in summary, if you must do the firmware upgrade on the XW+ make sure you follow all of the precautions stated by the colleagues in the post, and think twice if you really need it.  Particularly, make sure there are no loads to the system when attempting the upgrade, and be certain that Combox and switches/hubs in your network are not affected by even the slightest drop in power.  In my case, I have all of these devices on UPS and all loads were on a bypass transfer switch to the grid.  The new firmware upgrades are mostly addressing interactions with newer battery types  (i.e. Lithium with BMS).  I did it because the new firmware ( I was upgrading from 2.03), had bug fixes related to Load Shave block times, which I needed, otherwise I would have never bother. 

    Well, this had a happy ending, but it could have been fatal.  I hope you are not reading this after the fact.  As the colleagues in this forum said, you could ask first before doing anything.

    Alberto

    PS.  I am still waiting for Schneider's ticket reply....
  • Dave AngeliniDave Angelini Solar Expert Posts: 4,842 ✭✭✭✭✭
    It would not have been fatal as Schneider can recover an even worse Bricking than you had in this case. The reply may take a week or more. They really are not going to respond quickly to a DIY like they would to a registered installer.

     People may not like it but it is a way of life in many modern companies. I have worked with them on the side for over 20 years and have seen the changes. As long as they stay in business and support my clients I am happy, and build really great equipment.
    "we go where power lines don't" Sierra Mountains near Mariposa/Yosemite CA
     http://members.sti.net/offgridsolar/
    E-mail [email protected]

Sign In or Register to comment.