Trace SW4024 Charging Relay

HuntingCabin1HuntingCabin1 Registered Users, Users Awaiting Email Confirmation Posts: 1
Howdy, first time poster here.

So I have a Trace Engineering SW4024 running in my system with no problems. Or at least that is what I thought until I went to check my back up generator.

Power is getting to the inverter but once there the inverter doesn't see it.

I was told by a knowledgable neighbor that the generator relay block may have gone bad. 

I tested the continuity of the +/- inputs on the inverter generator blocks. They indeed were continuous but not sure that means much.

Are these relays replaceable? Is there another way I can verify that this is indeed my problem?

Thanks for any advice!

Jon

Comments

  • mike95490mike95490 Solar Expert Posts: 8,235 ✭✭✭✭✭
    First, verify your generator is producing power good enough for the inverter to qualify.  If the frequency is unstable or the voltage not correct (your inverter manual will have the specs it wants) it will never qualify.
    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

Sign In or Register to comment.