Outback Mate 3 LAN issues...

RandomJoe Solar Expert Posts: 472 ✭✭✭
I have posted this to the Outback forum as well, but in case anyone here has experienced similar issues and might even know of a solution...!

I have my solar system up and running again after the lightning strike a couple of months ago.  Had to replace the inverter, hub, Mate and FNDC.  I currently have a new FXR3048, Mate 3, Hub4, and (fortunately) the original FM80 CC is still working.

The Mate seems to work fine from its front panel but the LAN connectivity has several issues:

1) The LAN connection regularly drops!  It will come up and work for about 1.5 minutes, then drops for 30-45 seconds.  Lather, rinse, repeat.  The link light goes out when it drops.  I've tried it with two different switches and changed cables just to be sure, same behavior.

I am using a fixed IP, have tried both setting the IP in the Mate and leaving the Mate on DHCP and making a reservation in my DHCP server.

I have OpticsRE disabled (not using it) and every time the interface comes back up the Port screen shows OpticsRE is connecting!  Then it goes to "disabled" a few seconds later.

2) The web interface is flaky.  When I initially set up the Mate it was completely unusable, always showed "please enable javascript" even though it was.  The firmware was 3.15.0 and a forum search showed the latest fixed that.  I updated to 3.15.5 and that problem was fixed - for a while.  Now I get *some* data but not all, and the graphics never show up.  At the top of the screen it says "please wait while loading config".

3) I want to use the LAN "data stream" with my home automation system and it does work (when the LAN connection is up!) but it only supplies data for the charge controller, port 2!  I never see any data for the inverter...  (Don't have the replacement FNDC yet so don't know if it'll show up or not...)

I've not had a very impressive first experience with the Mate 3 unfortunately...  The first one I was shipped was dead out of the box, this one seems to be handling the solar functions fine but other parts seem fairly buggy.  Quite a letdown after the rock-solid "Just Works" experience with the old style Mate on my original system!


  • RandomJoe
    RandomJoe Solar Expert Posts: 472 ✭✭✭
    Called tech support today and worked with them a bit. We did "fix" the connection dropping - by re-enabling OpticsRE! Apparently even when it's disabled there's something seeing it isn't connected and triggering a reset...?

    They had me reflash the firmware just to be sure, but still no joy on the internal web page and data streaming issues. They said they didn't recommend going backward with the firmware so they're just going to send another Mate to me so I can give it a try.

    Third time's the charm, I hope...?!
  • RandomJoe
    RandomJoe Solar Expert Posts: 472 ✭✭✭
    Third time is NOT the charm, unfortunately...

    The replacement Mate 3 arrived today and I connected and configured it.  

    The only "success" at this point is that the internal web page is - for now - working.  But then it worked on the previous Mate - for a while...  We shall see if it continues to function...

    It still resets the network port regularly if OpticsRE is disabled, and it still doesn't show the inverter (port 1) on the data streamer.

    I called Outback and talked with tech support again.  Their final "answer" is that the Data Streaming function is NO LONGER SUPPORTED!  It's been "obsoleted" by OpticsRE.  Phooey.

    I then asked if that included the serial port interface and was told he didn't know.  Very helpful...  I wasn't keen on spending $70 when I should be able to get the data over the LAN, I'm sure not spending it only to find it doesn't work properly either!

    They wanted to know why I didn't use OpticsRE.  -- Because it's unnecessary!  I want to monitor and log my systems using my own software on my own machines.  Sending the data across the internet to someone else's servers just to bring it back home again is ridiculous!  

    I'm very unimpressed and disappointed... :( 
  • Raj174
    Raj174 Solar Expert Posts: 795 ✭✭✭✭
    If you search the word "stream" on Outback's forum, it gives much info on what other folks have been and are doing to solve similar issues. 

    4480W PV, MNE175DR-TR, MN Classic 150, Outback Radian GS4048A, Mate3, 51.2V 360AH nominal LiFePO4, Kohler Pro 5.2E genset.
  • RandomJoe
    RandomJoe Solar Expert Posts: 472 ✭✭✭
    I have, at least, found another way to do this...  After thinking about it for a while today I recalled briefly playing with a CGI interface.  Could NOT remember where I'd seen that, but did finally dig up this document:

    Guide To MATE3 Data Use - Outback Power

    It shows the URL form to get a plain-text JSON dump of the same info you'd get with the Data Streamer.  Would be nice if this was mentioned in the manual!

    Of course that same document also has a section at the end titled "Why Use Data Streaming?"  Guess they'll need to update that document now...

    Raj174 said:
    If you search the word "stream" on Outback's forum, it gives much info on what other folks have been and are doing to solve similar issues. 


    Yeah, I'd seen several of those threads.  Unfortunately the only really viable option seems to be to go back to an old firmware, pre-OpticsRE.  That does seem to be the feature add that's causing the problems.  Not only with the simple data streamer, but also with Modbus.

    Initially I wasn't necessarily opposed to OpticsRE, I just don't need it and - contrarian that I am - now I've been told I *have* to enable it just to get a stable network connection I'm pretty well set against it! :naughty:  I may even sniff the network traffic and see if I can't find a way to simulate the server side of the connection on my firewall so the Mate *thinks* it is connected even though it's blocked.  

    (I do wonder / worry just how "connected" it is - does their server collect any data from my system before I set up an account?  Is there any possibility someone malicious could manage to take control of that link?  For that matter, having never even looked at OpticsRE is it monitor only or can things be controlled?  These are reasons why I'd prefer just to turn it off.)
  • Dave Angelini
    Dave Angelini Solar Expert Posts: 6,746 ✭✭✭✭✭✭
    Both Optics and Schneider Solar's Insight only "push" certain data about the system out to the web. They are pretty much totally safe from malicious control. That said, it seems ridiculous that you can't get the Outback system to work right locally only. I will take a look at a clients who runs Outback and like you does not want anything going "out". 
    "we go where power lines don't" Sierra Nevada mountain area
    E-mail offgridsolar@sti.net