Xw6048 not charging with generator

GenericGeneric Registered Users Posts: 27
So far this has been the most cloudy month in the 4 years since I've gone off grid so I'm in need of some supplemental power from my solar. I bought a new Generac 3250 120/240v generator and hard wired it to my power distribution panel.
The xw6048 ac2 gen light flashes and when it tries to start charging it just clicks off after about 4 seconds and tries again every 30 seconds. I unbounded the generator's neutral to ground. Both legs voltages to neutral are exactly 120. I changed the charge rate setting to 5% which is the lowest possible. I also tried wiring directly to ac2 and ac1 inputs and same thing. The generator will power all my loads just fine using the inverter bypass switch.
I'm out of ideas to try to get it to work. I really would like to just charge the battery bank every once in awhile when needed.
Thanks for any ideas or help.


  • BB.BB. Super Moderators, Administrators Posts: 30,505 admin
    Do you know what the frequency of your genset is?

    AC1 probably is set to +/- 1.0 Hz (60Hz) or so... The AC2 may be set to something like +/- 5 Hz for a genset.

    Near San Francisco California: 3.5kWatt Grid Tied Solar power system+small backup genset
  • BrockBrock Solar Expert Posts: 633 ✭✭✭✭
    If you can put a meter on the genset side and watch it when the inverter tries to connect.  I am guessing, as Bill noted, the Hz is falling out of range or the voltage is as well.  If it were me I would slowly set the range for voltage and Hz wider until the inverter can sinc with the genset.  Even with the AC2 set for say 5 amps when it first connects it will try to pull whatever loads it see which bog down the genset.
    3kw solar PV, 8 L16's, xw 5548, Honda eu2000i, iota DLS-54-13, Leaf EV, 4 ton horizontal geothermal, grid tied - Green Bay, WI
  • GenericGeneric Registered Users Posts: 27
    Well my voltmeter can't read frequency. The scp shows both ac2 line voltages at 122v and 63hz at idle. It is set to accept 80-140v and 45-70hz.
    When it tries to connect the voltage goes up to 131v and the ac2 amps in on each line goes to about -3 and it resets. Does that mean it's trying to put energy into the generator?
  • GenericGeneric Registered Users Posts: 27
    Weirdest thing, I went to check the voltage on the generator side when it tried sync. It shot up to 140v then went down to 124v but it didn't drop back to idle. Sure enough it had synced and was chargin at 5amps. It charged for about 5 minutes and I flipped the breaker and up the max charge rate to 10%. Flipped the breaker back and it synced up and is charging at 10 amps now just fine.
    I should be happy but I have a feeling this won't keep working.
  • GenericGeneric Registered Users Posts: 27
    Oh and the ac2 amps in still shows -2.7 and -4.5 on the two lines while charging at 10 amps so I guess that's normal. But for some reason ac1 in line 1 shows 2.7 amps and nothing is even hooked up to it.
  • GenericGeneric Registered Users Posts: 27
    The only difference between it failing last night and working today is the batteries were low last night and today they had more charge from the solar. Maybe that was enough to let the generator not peak above 140v which is the max setting for the charger to accept. Is there anyway to lower that surge on the generator? I'm thinking maybe plug in an electric heater to it to get it producing just before trying to sync it to the charger.
  • mrfixitmrfixit Registered Users Posts: 16 ✭✭
    Mine would do that same thing,what I did that worked was a simple 150watt heat lamp plugged directly into the generator.
    With the lamp on it syncs every time,I think it helps keep the generator voltage from spiking.
    After it syncs up I just turn the lamp off.Pretty high tech.
  • soloronesolorone Solar Expert Posts: 254 ✭✭✭
    edited December 2015 #9
    I missed reading a post.. Edit ,,  I set the genset for  61 Hz  on XW 4024 and they sync very well.
  • mike95490mike95490 Solar Expert Posts: 8,762 ✭✭✭✭✭
    Glad you got it figured out.  AC2 should have a pretty wide Fq allowance, 55hz - 65hz  Generators are not always super stable as their load varies.
    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

  • new2PVnew2PV Solar Expert Posts: 305 ✭✭
    10 amps does not seem very much for a 3.2 kw gen.  I am able to charge at 40 amps with my eu3000is with no other loads and 20 amps with loads attached, but any surges and the xw dumps the gen, even with gen support enabled.
    XW6848 inverter with 2 X mppt 60 150 CC , with Canadian solar 260Watt panels 2 x 3.5 kw array
  • GenericGeneric Registered Users Posts: 27
    Just an update, everything has been working fine since my initial problems. Not sure why there was issues to begin with. Maybe the generator just needed to be broke in a little. I have it set up to charge at 40 amps which leaves a little wiggle room on the generator.
Sign In or Register to comment.