Xantrex GT 2.5 issues

Hi, first time visiting this site. My 3rd Xantrex has now gone haywire and this time it's out of warrantee. I'm running 16 120w panels. The inverter powers up fine but kicks off when it reaches ~400 watts, it then starts at 0 and slowly works up toward 400w and then kicks off again. It continues this cycling until the sun goes down; no fault or error codes. I measured 300vdc at the input.

I called tech support and they simply stated that the unit was toast and for a flat fee of $800 plus shipping, they would fix it. Not likely to spend close to $1000 to get yet another failing unit, I opted to replace it with a Sonny Boy. In any case, I now have the Xantrex sitting in the basement and was wondering if this may have a simple fix.

Any ideas?

Thanks

Comments

  • BB.BB. Super Moderators, Administrators Posts: 29,980 admin
    Re: Xantrex GT 2.5 issues

    There are some folks that do repair inverters... Here is a post with some people that may repair your inverter:

    #64

    Anything special going on? Lightning nearby? Running hot (in a garage/closed airspace with poor circulation), if full sun, etc.?

    In general, electronics that run 10+ years--Usually a good life. Those that fail in 5 or less years--Not good.

    Also, if you can run them cool (every 10C increase in operating temperature is ~1/2 the expected life of the device). Also avoiding extreme temperature cycling is very helpful too.

    SMA makes some nice/reliable GT inverters--But they are not cheap...

    -Bill
    Near San Francisco California: 3.5kWatt Grid Tied Solar power system+small backup genset
  • mike95490mike95490 Solar Expert Posts: 8,569 ✭✭✭✭✭
    Re: Xantrex GT 2.5 issues

    do you get any error message, or monitor the system? If the local grid is running too high of voltage, as your inverter feeds the grid, it could trip offline from overvoltage on the Grid.
    That's my guess from the symptoms.
    Powerfab top of pole PV mount | Listeroid 6/1 w/st5 gen head | XW6048 inverter/chgr | Iota 48V/15A charger | Morningstar 60A MPPT | 48V, 800A NiFe Battery (in series)| 15, Evergreen 205w "12V" PV array on pole | Midnight ePanel | Grundfos 10 SO5-9 with 3 wire Franklin Electric motor (1/2hp 240V 1ph ) on a timer for 3 hr noontime run - Runs off PV ||
    || Midnight Classic 200 | 10, Evergreen 200w in a 160VOC array ||
    || VEC1093 12V Charger | Maha C401 aa/aaa Charger | SureSine | Sunsaver MPPT 15A

    solar: http://tinyurl.com/LMR-Solar
    gen: http://tinyurl.com/LMR-Lister ,

  • SkiDoo55SkiDoo55 Solar Expert Posts: 414 ✭✭✭
    Re: Xantrex GT 2.5 issues

    Is that 300 VDC input while under loaded conditions or when it's not producing. I would try and monitor the VDC In while it is cycling Do you have the RS232 serial hooked to a PC with GT View/SG View etc; running, if you did you could set to log every 10 to 15 seconds and have a pretty good picture of what was going on.So far my Zantrex GT3.8 has beeen working flawlessly for 0ver 4+ years and has produced 28MWh todate. Sorry to hear of your problems with the GT2.5
    GT3.8 w/4600W Trina 230W, TX5000 w/5000W ET-250W, XW4024 w/1500W ET-250W, 4 L16, 5500W Gen. (never had to use) Yet!!
  • Oha RidgeOha Ridge Registered Users Posts: 2
    Re: Xantrex GT 2.5 issues

    Thank you for the replies and the links to repair people!

    There were no error messages, it quit while I was away for a month and we did have an active lightning summer while I was away, no idea if anything hit nearby (fwiw I have lightning protection on both the AC and DC sides), it's mounted in a large basement space so a fairly constant 55-60°f ambient, the 300vdc is open circuit I never measured it as it was cycling (right now it is at 244vdc running the new SMA and has produced 42kwh in the last four days)

    Again, thank you all for the help!! I may still see about having it fixed or selling it to someone that wants to fix or have fixed....
Sign In or Register to comment.