help please no lights

i have a trace dr series dr 3624 off grid sys it does not light up any where power going in to the load controller but not coming out we meter it .....it is the trace unit as well we have 20 batterys 10 panals 120 watts ............can you please help thank you devin wiser and friends

Comments

  • hillbillyhillbilly Solar Expert Posts: 334 ✭✭
    Re: help please no lights

    Ok, no offense but that is one of the most vague posts I've seen yet... but I would be more than willing to help (and I am sure that there are others FAR more learned than I who may chime in as well). Thing is you've got to be just a bit more specific about what EXACTLY is going on.
    Couple of real obvious questions that even I can see are:
    have you had this system hooked up and running before, or is this the very first time that you've connected everything?
    What exactly does it mean when you say "power going in the load controller but not comming out"?
    You mention "20 batteries".... I am assuming that these are all 6V hooked up as 5 sets of 4? And are you absolutely sure that those are hooked up correctly?
    Spell it all out a bit more and I am sure you'll have lots of help here,
    Good luck
  • System2System2 Posts: 6,290 admin
    Re: help please no lights

    used new to us ,,,,,we have 24 volts set up with 4 batterys now to test it and befor placing them ......the sys is 2002 we have 4 panals hooked to the sys .........the inverter....no power out of the load controller or lights on ........the load controller........there is power showing going in the load controller ......nothen coming out .......do the batterys have to be fully charge ?? its all kyocera the inverter is a dr series dr 3624 and load c is the trace with the remote unit but no remote is present ....it does have the phone jack and ldc panal ...we hope this is more info ......
  • System2System2 Posts: 6,290 admin
    Re: help please no lights

    the load unit is a c 40 .......and the batterys are old we intend on new ones soon we do have good ones to test with just dont want to move them yet ..................
  • System2System2 Posts: 6,290 admin
    Re: help please no lights
    used new to us ,,,,,we have 24 volts set up with 4 batterys now to test it and befor placing them ......the sys is 2002 we have 4 panals hooked to the sys .........the inverter....no power out of the load controller or lights on ........the load controller........there is power showing going in the load controller ......nothen coming out .......do the batterys have to be fully charge ?? its all kyocera the inverter is a dr series dr 3624 and load c is the trace with the remote unit but no remote is present ....it does have the phone jack and ldc panal ...we hope this is more info ......

    1) Do you have 4 batteries, 6 volts each, wired in series to give 24 volts?
    2) The "load controller" - - do you mean the Charge Controller which regulates the charge going into the batteries? If yes, what is the model number?
    3) "No power showing going to the load controller" - - Do you mean no power coming from the Solar Panels and going to the Charge Controller?
    If no power goes into the Charge Controller, then for sure nothing will come out of it.
    4) What do you have for Solar Panels? And how many?
    5) If the batteries are partly discharged, 21 volts or less, the inverter most likely will NOT operate.
    First make sure batteries will charge and get them charged up if possible.
    Used batteries are often not good.
    Cheers
    Wayne
  • System2System2 Posts: 6,290 admin
    Re: help please no lights

    has any one heard of a factary recall on the kyocera kc120-1 2002 ..........???????????????????????????????
  • System2System2 Posts: 6,290 admin
    Re: help please no lights

    1? yes 2? trace c40 3? 37 volts coming from panals 4? we have 4 kyocera 120 kc120-1 hooked up to it now 5? we are trading them in now thank you
  • NoodlesNoodles Solar Expert Posts: 30 ✭✭
    Re: help please no lights
    has any one heard of a factary recall on the kyocera kc120-1 2002 ..........???????????????????????????????

    I am unaware of a "recall", however they have replaced many under warranty. You can call them at 1-800-544-6466.
  • Solar GuppySolar Guppy Solar Expert Posts: 1,962 ✭✭✭
    Re: help please no lights

    Your C40 is powered from the battery connections, so if you have no voltage on the batterys the controller cannot operate regardless if the PV input has solar panels connected
  • System2System2 Posts: 6,290 admin
    Re: help please no lights

    thank you wayne .........it was the low cells ..........it lights up ....there is hope ....................thanks agian
  • BB.BB. Super Moderators, Administrators Posts: 29,832 admin
    Re: help please no lights

    Yes, Kyocera has replaced k-120 panels under warranty... Don't know the year range, but those built in 2001 were included.

    A quick Kyocera 120-watt panel thread on Solar Guppy's forum.

    -Bill
    Near San Francisco California: 3.5kWatt Grid Tied Solar power system+small backup genset
  • System2System2 Posts: 6,290 admin
    Re: help please no lights
    thank you wayne .........it was the low cells ..........it lights up ....there is hope ....................thanks agian

    You're very welcome, but I only asked questions. LOL
    As always, others with much knowledge and experience chimed in with great information.
    This is the most awesome, helpful, non-BS form I've ever had the privilege of playing a part.
    And that, ladies and gentlemen, is why I keep coming back. I help where I can and learn where I can.
    Thank you NAWS for providing this great form!
    Wayne
    ________
Sign In or Register to comment.