lost control

SystemSystem Posts: 2,511 admin
I have a whisper 200 wind gemerator replaced batteries but didn't disconnect gemerator from controler before disconecting batteries. fried controler? is there an easy/cheaper fix other than buying a new controler?


  • BajaGringoBajaGringo Solar Expert Posts: 40 ✭✭
    Re: lost control

    You may have damaged the turbine itself as well, depending on the setup. Did you install it yourself or did you pay someone? Sounds like it's a prime moment to step back and bring in some know-how...
  • GreenPowerManiacGreenPowerManiac Solar Expert Posts: 453 ✭✭✭
    Re: lost control

    I know that on a more advanced MPPT controller, there are a couple ways of wiring to get the same result. My setup is like this: wiring from the turbines goes straight to the batteries and the diversion load releases the extra energy through an out, like a shunt or something DC powered.

    Should have stopped the turbine first and tied up the blade for temporary maintenance, however, too late now.

    I believe what you need to do is test the controller positive/negative output with the unit spinning. If you get voltage from the normal hookups, you're good. No voltage or low voltage would indicate the above dilemma. Buy a good controller with a diversion load. Mine is a Morningstar TS-45 with digital display. Expensive it is, however will give you assurance that it will do its job and alert you when an error is made.
    Nature's Design & Green Energy on FaceBook : Stop by and "Like" us anytime.. Many up-to-date articles about Renewables every day.
    WWW.GreenAnything.Net    Ad free website.
    Lots of DIY Renewable Energy Projects on ETSY : Solar Panel builds, Wind Turbine builds, Rain Barrel build,etc.  
  • peterakopeterako Solar Expert Posts: 144 ✭✭
    Re: lost control

    Hi what type off voltage configuration do you work with 12, 24 or 48 V

    The 48V configuration if disconected from battery in high wind can produce high input voltage to the board but the others stay in safe limit.

    Dit you tryed to reset the board after connecting the battery ( make sure that the voltage is on the battery terminal).
    I have seen one time freezing up from the board because of connection sparking and a reset solved the problem.

    Greetings from Greece8)
  • solarvicsolarvic Solar Expert Posts: 1,053 ✭✭✭✭
    Re: lost control

    If you can,t get it to work you can probably get Southwest windpower to repair it. I called them once and they said they can repair them. S:Dlarvic
Sign In or Register to comment.