Flexmax 80 problems

adasadas Solar Expert Posts: 136 ✭✭✭✭✭
Aloha, all, it has been a while since I was on this board. I have 3 Outback Flex 60's and 3 Flexmax 80 controllers and although the warranty service has been great, lifetime of the product does not seem to be. 2 had LCD malfunctions right out of the box and 2 other Flexmax 80's just fried. I am running at 92-100 v from my panels and basically are running at 65-75 or so amps ALL day. Am I expecting too much out of these controllers? Any one else have problems with the "early" Flexmax80's. Is there any other controllers better? thanks
Frank

Comments

  • nielniel Solar Expert Posts: 10,300 ✭✭✭✭
    Re: Flexmax 80 problems

    actually, i am surprised as to your report of their performance. outback does have good service so give them a chance to make things right.
    if you wish to get different controllers at this time there's the xw from xantrex as well as the apollo (hoped i spelled that right).
  • adasadas Solar Expert Posts: 136 ✭✭✭✭✭
    Re: Flexmax 80 problems

    Aloha, no problems as Outback has been very good with their warranty so far, so I will call them tomorrow. I have to buy 2 more "80's" as well as one for warranty so just was wondering if anyone else had similar problems with the early models?

    frank
  • BB.BB. Super Moderators, Administrators Posts: 30,645 admin
    Re: Flexmax 80 problems

    There have been reports of problems with the units reporting "charging" at night--Have not heard that that problem has been fully fixed yet.

    FM Night Current

    The Apollo--Windsun discontinued them:

    Apollo Notice

    Solar Guppy may be a bit biased (he was involved with the design and evaluations ;) )--But he is is very happy at this time with the Xantrex XW 60 charge controller.

    -Bill
    Near San Francisco California: 3.5kWatt Grid Tied Solar power system+small backup genset
  • crewzercrewzer Registered Users, Solar Expert Posts: 1,832 ✭✭✭✭
    Re: Flexmax 80 problems

    Frank,

    Sorry to hear about the CC issues. Please keep working with Customer Service.
    I am running at 92-100 v from my panels and basically are running at 65-75 or so amps ALL day.

    Office System. 3940W * BP 40x70W * Sun 12x190blems * 2xFX80 * 2xMX60's * 4x625AH 24(36)v Batteries (Used Forklift Type)
    Warehouse System 4560w * Sun 24x190Wblems * 2xFX80's * 4x875AH 24v Batteries.(Used Forklift Type)
    Could you provide us with more detailed info about your system configuration? For example, I don't understand the "3940 W" spec, as (40 x 70 W) + (12 x 190 W) = 5080 W.

    How are the "office system's" various modules wired up for the two FX80's and two MX60's?

    IIRC, you're running 24 V systems?

    Is the "92-100 V" spec observed (i.e., is it displayed on the CC when it's operating in B-MPPT mode), is it the STC Vmp spec for the arrays, is it the STC Voc spec for the arrays, or?

    Thx,
    Jim / crewzer
Sign In or Register to comment.