KID update froze

ws9876ws9876 Solar Expert Posts: 332 ✭✭✭
I tried to do an update on the KID firmware. I verified that I was on 12 volt and it saved it. Then I dragged the new firmware file into the pop up box but the screen had broken up text on it and them it said firware 2.2  Bad Firmware..... and I cant get out to the main menu. Its stuck
on this screen. I disconnected the battery and reconnected but I still cant get out of the screen. I took the back off and I notice that there is a small hard reset button ...should I hit it??


  • ws9876ws9876 Solar Expert Posts: 332 ✭✭✭
    solved.... I had to extract the files before it took them in Ubuntu....then it worked but it takes a few seconds to react and start..
  • VicVic Solar Expert Posts: 2,938 ✭✭✭✭

    OK ws..,    Good that you have solved the issue.

    The KID is a neat,   medium-sized MPPT CC.    Have fun with it,    Vic

    Off Grid - Two systems -- 4 SW+ 5548 Inverters, Surrette 4KS25 1280 AH [email protected], 11.1 KW STC PV, 4X MidNite Classic 150 w/ WBjrs, Beta KID on S-530s, MX-60s, MN Bkrs/Boxes.  25 KVA Polyphase Kubota diesel,  Honda Eu6500isa,  Eu3000is-es, Eu2000,  Eu1000 gensets.  Thanks Wind-Sun for this great Forum.
Sign In or Register to comment.