Dead Windseeker 800

arcandsparkarcandspark Solar Expert Posts: 63 ✭✭✭✭
I have been working on a friiends solar install for a number of years, continously adding on to the system. He purchased a Windskeer 800 back in 1999 and had it in dry storage. He wanted me to install it so I took it home to test it. I assemble the unit and installed it on a temperary pole hooked up to a 24 volt battery bank that was reading about 22 volts, with an amp meter wired in. With wind spinning the blades at a high rate I saw no output current coming from the generator. Southwest tells me they removed the Windseeker 800 from their product line because it had problems, they also said they could not service the unit but would sell me a new generator unit. So much for their help. So my friend is stuck with a new in the box Windseeker and a guy wire support tower kit. I am looking for some place that might be able to serice the generator, if not my friend says to just sell the parts off on ebay. Anyone need parts for a Windseeker 800 of have any suggestions for repair. From what I see the unit was bad from the factory because it did not work right out of the box. My friends lesson to everyone else, if you purchase something, test it right away, dont wait eight years. arcandspark

Comments

  • halfcrazyhalfcrazy Solar Expert Posts: 720 ✭✭✭
    Re: Dead Windseeker 800

    I would open it up there may be something obvious I got a brand new DR inverter from trace and got 5 hours from home to install it in place of a lightning struck unit and it didn't power up.
    i opened the cover and the positive lead from the stud to the unit inside wasn't crimped and had fallen out i crimped it and all was good. if you don't see anything obvious try posting on otherpower and there will be someone that can walk you thru troubleshooting
Sign In or Register to comment.