MPPT60 Not Communicating with PC

I have been using my MPPT60 charge controller for about a year and the other day, it stopped communicating with my router/PC. The MPPT is wired to my RV's D-Link Wireless Router and I connect my laptop to the router to communicate with the MPPT. I can ping the MPPT and it responds. I run MSView, I tell it to search for the controller and it finds it, I double click on the controller and I eventually get the following message, "Error: unable to open connection to TriStar-MPPT: controller did not respond to Modbus Read Basic Device Identification". I also tried http://tsmpptxxxxxxx/test.html and I get no response back. I try 192.168.1.253:502 and get no response back. I try 192.168.1.253/datalog.html, no response, same with .... iveview.html, no response. I have contacted MorningStar support and they told me to use MSView, which sees the controller, but does not open it for communications. I have isolated the controller from both the batteries and solar panel and it reset when I reconnected the batteries, no luck. I cant even get into the controller to reset it to factory default settings. I wish there was a button that would reset the controller to factory settings, but no such luck.
Has anyone else encountered this problem. No problems until now.
Any thoughts?
Thanks in advance for any assistance you may have to offer.
Don

It looks like I may have to try MorningStar support for a 3rd time.

Comments

  • Mustang65Mustang65 Solar Expert Posts: 42 ✭✭
    Re: MPPT60 Not Communicating with PC

    Issue Resolved:

    I opened MSView kept selecting the PROGRAM TSMPPT button with the defaut options and on the 11th or 12th time in a row, for some reason it took it. I then reprogrammed it with my saved options and it is now back to working again. I though that I was going to have to send it back to MorningStar for service. No clue as to what the issue was/is, but it is up and running again. Remote access is back up and working.
Sign In or Register to comment.