Xantrex GT 3.3 NA 240 acting up

Hi everyone
I have an Xantrex GT 3.3 NA 240 installed with a 2.6 KW tracking array. Lately it has been acting up. What happens is that it connects and starts loading the unit until the pv array voltage drops to 360 V, and then it disconnects, green online led goes out, and about 8 seconds later, it reconnects and loads back down to 360 volts, where it disconnects again. Sometimes tapping the inverter with a rubber hammer will get it to connect past the 360 V point, and then it is generally good for the rest of the day. The next morning, it displays the same problem. No fault codes on the display. We've checked the panels and wiring, and everything seems OK.

A call to Xantrex was made, and they say they've seen this problem before. They will not fix it out of warranty, but will only offer through their "customer loyalty program" a new unit for $1440 plus shipping and tax. I find that unbelievable!

I am tempted to try a different manufacturer after this BS.....i'm thinking of the SMA 3000hfus.....but before I do that, I think it might be worthwhile to examine the main board where all the heat is generated and perhaps see some degraded solder joints. What do you guys think? Have you ever seen this before, and do you have any idea where I should look?
Thanks
Al

Comments

  • nielniel Solar Expert Posts: 10,300 ✭✭✭✭
    Re: Xantrex GT 3.3 NA 240 acting up

    seeing as xantrex won't fix it then you have 3 choices.

    1> try to fix it yourself.

    2> get another inverter.

    3> do both 1 and 2.

    you may actually find what's ailing the inverter and fix it, but it was most likely stressing the parts within so it may fail soon in the future too even if you get it going now. add to that that the parts will go obsolete or may already be obsolete. if it were me i'd say get another inverter new (your choice as to who) and if you get that one to work in the mean time then keep it as a spare or sell it. a rap on it does say it's probably something physical to look for like loose heat sinking, bad solder joints, etc., possibly even insects messing it up.
  • solarvicsolarvic Solar Expert Posts: 1,060 ✭✭✭✭
    Re: Xantrex GT 3.3 NA 240 acting up

    I would have a hard time bieing loyal at that price. Have a look at fronius. There are dealers selling 3. 0 plus models for less than $1300.00 and the 3.8 plus model for about the same money that xantrex wants to replace under an owner loyalty deal. :Dsolarvic:D
  • vtmapsvtmaps Solar Expert Posts: 3,741 ✭✭✭✭
    Re: Xantrex GT 3.3 NA 240 acting up
    Alan B wrote:
    Sometimes tapping the inverter with a rubber hammer will get it to connect past the 360 V point, and then it is generally good for the rest of the day.
    <snip>
    A call to Xantrex was made, and they say they've seen this problem before.
    niel wrote: »
    a rap on it does say it's probably something physical to look for like loose heat sinking, bad solder joints, etc., possibly even insects messing it up.

    Alan, welcome to the forum. In addition to what Niel mentioned, it sounds like it might be a sticking relay. If xantrex knows what the problem is, ask them to explain it. If/when they do, please follow up and tell us about it. We have a forum member, "crewzer" who works for xantrex. He might not have seen your post. try sending him a PM. He is very helpful.

    --vtMaps
    4 X 235watt Samsung, Midnite ePanel, Outback VFX3524 FM60 & mate, 4 Interstate L16, trimetric, Honda eu2000i
  • nielniel Solar Expert Posts: 10,300 ✭✭✭✭
    Re: Xantrex GT 3.3 NA 240 acting up

    vtmaps brings up a good possibility with the relay. sometimes it is just a bit of oxidation on the relay contacts and that is setting up a high resistance or the relay is hanging up for some reason. if you go to clean the relay contacts do be very careful not to use something that's too abrasive. extremely fine sandpaper like #600 or preferably higher and only a few swipes. i would try a chemical cleaner first on a lint free cloth and swipe through the contacts. of course it may be inaccessible all together and you'd need to possibly change the relay. all this is assuming it is the relay at all as there's many possibilities.
  • Alan BAlan B Registered Users Posts: 2
    Re: Xantrex GT 3.3 NA 240 acting up

    Thanks for your suggestions.

    I tried sending crewzer a PM, but his mailbox was full, so no luck there.

    I suspect it might be something other than a relay, as there is no clicking from the unit, except during a cold restart and initialisation, but the problem starts after the green online led illuminates. I've listened intently, listening for a relay, but have never heard anything.

    I've looked at the Fronius IG plus 3.0-1 and the SMA 3000hfus, and they are both around $2000 at the places I've checked. Xantrex's replacement seems to be the cheapest option so far.....but all the service issues I've read about makes me leery about paying for another Xantrex. Not to mention their explanation that 4-5 hours to repair at $125/hr plus the cost of a new main board makes it cost prohibitive. I personally find it hard to believe it would take that long....pretty poor design if that is in fact correct!

    They tell me it is a redesigned inverter, so perhaps they have resolved the older problems.

    Al
Sign In or Register to comment.