Link 10 Voltage Display

fatheadlfatheadl Solar Expert Posts: 31 ✭✭
Hi All,

I just installed a new Xantrex link 10. The voltage display keeps fluctuating +/- 0.5 volts of the battery voltage. Is this normal?.

Thanks in advanced

fatheadl

Comments

  • crewzercrewzer Registered Users, Solar Expert Posts: 1,832 ✭✭✭✭
    Re: Link 10 Voltage Display

    No, that's generally not normal. Exceptions could include rapid changes in charge/discharge current to/from a small battery bank. My Link 10's V display is fairly steady, and it changes in 0.1 V increments.

    Some suggestions:

    1) Make sure the shunt sense wire pair from the shunt to the meter is twisted together to help minimize noise pickup by this very sensitive circuit.
    2) Keep the shunt sense wire pair away from electrical noise sources.
    3) Double check all of the meter wiring and connections per the instructions.
    4) Check the manual's troubleshooting guide.

    HTH,
    Jim / crewzer
  • fatheadlfatheadl Solar Expert Posts: 31 ✭✭
    Re: Link 10 Voltage Display

    Hi Jim,

    The 'Amps' display is steady, it's only the 'Volts' display. The battery bank is 12v

    Thanks in advanced
    fatheadl
  • rplarryrplarry Solar Expert Posts: 203 ✭✭✭✭✭
    Re: Link 10 Voltage Display

    Just checked mine and it bounces around by 5/100 (.05) of a volt. Half a volt would not be normal.
    larry
  • fatheadlfatheadl Solar Expert Posts: 31 ✭✭
    Re: Link 10 Voltage Display

    Hi All,
    My mistake +/- .05, so i guess that this is normal then.

    Thanks for the replies.
    fatheadl
Sign In or Register to comment.