Morningstar ts 60 mppt charge controller problems ?

GatorGator Posts: 29Registered Users ✭✭
I shut everything down, panels, inverter and controller/battery disconnect in order to re route solar connectors on roof of my trailer.
I FINISHED THE JOB and came inside to turn everything back on.
Thats when everything went south...
I turned on the controller battery switch and waited till it came to screen that said night and the red/YELLOW led was on.
After a couple of minutes I turned the solar panels on.
Thats when the controller started alternating yellow/ red then green/ red  continuous and then after showing fault/absorb back and forth a few times it would say starting and amps showed different amounts dropping down to 0 amps and alternating absorb/fault, all the while.
I re booted the controller a few times from scratch with the same result.
1 time i turned on the inverter and it made a little poping noise and controller screen went blank.
Seems, i think that there is a short somewhere?

I'm really deoressed cuz i dont kno wat i did to cause any of this or how to fix it..

HELP ME PLEASE IF SOMEONE CAN?

AS I SAID ...MORNINGSTAR TS 60 MPPT CHARGE CONTROLLER (150 WATTS)...., SAMLEX 2000 WATT 24 VOLT INVERTER,....(3) PANASONIC H.I.T. 330 WATT. PANELS

TOTALLY OFF GRID!

.HELP...HELP

Comments

  • PhotowhitPhotowhit Posts: 4,481Solar Expert ✭✭✭✭
    You didn't happen to switch polarity?
    Home system 4000 watt (Evergreen) array standing, with 2 Midnite Classic Lites,  Midnite E-panel, Prosine 1800 and Exeltech 1100, ForkLift battery. Off grid for @13 of last 14 years. 1000 watts being added to current CC, @2700 watts to be added with an additional CC.
  • littleharbor2littleharbor2 Posts: 877Solar Expert ✭✭✭✭
    Hopefully you haven't series wired those high voltage panels. 3 in series have a Voc. of 209 volts. Magic smoke time.

    2.1 Kw Suntech 175 mono, Classic 200, Trace SW 4024 ( 15 years old  but brand new out of sealed factory box Jan. 2015), Bogart Tri-metric, 700 ah @24 volt AGM battery bank. Plenty of Baja Sea of Cortez sunshine.

  • GatorGator Posts: 29Registered Users ✭✭
    Not Series....all pos 3 into 1...all neg 3 into 1
  • GatorGator Posts: 29Registered Users ✭✭
    I couldnt switch polarity cuz mc4 neg and pos are different connectors, and i connected same as i took apart
  • GatorGator Posts: 29Registered Users ✭✭
    Thinkin....gotta chk inverter hardwire to ac panel...connection mighta come loose and is shorting possibly?
  • GatorGator Posts: 29Registered Users ✭✭
    But why now? B4 was working with no problems?
  • EstragonEstragon Posts: 2,219Registered Users ✭✭✭✭
    > @Gator said:
    > I couldnt switch polarity cuz mc4 neg and pos are different connectors, and i connected same as i took apart

    Do you have mc4 connectors at the controller? At the combiner?
    Off-grid.  
    Main daytime system ~4kw panels into 2xMNClassic150 370ah 48v bank 2xOutback 3548 inverter 120v + 240v autotransformer
    Night system ~1kw panels into 1xMNClassic150 700ah 12v bank morningstar 300w inverter
  • EstragonEstragon Posts: 2,219Registered Users ✭✭✭✭
    > @Gator said:
    > Thinkin....gotta chk inverter hardwire to ac panel...connection mighta come loose and is shorting possibly?

    Flip the Dc breaker to turn the inverter off until you're sure the DC side is righteous.
    Off-grid.  
    Main daytime system ~4kw panels into 2xMNClassic150 370ah 48v bank 2xOutback 3548 inverter 120v + 240v autotransformer
    Night system ~1kw panels into 1xMNClassic150 700ah 12v bank morningstar 300w inverter
  • EstragonEstragon Posts: 2,219Registered Users ✭✭✭✭
    What is the actual battery voltage?
    Off-grid.  
    Main daytime system ~4kw panels into 2xMNClassic150 370ah 48v bank 2xOutback 3548 inverter 120v + 240v autotransformer
    Night system ~1kw panels into 1xMNClassic150 700ah 12v bank morningstar 300w inverter
  • GatorGator Posts: 29Registered Users ✭✭
    Got inverter disconnect off....have (4) UPS batts. With 80 amh series / parallel .....batt voltage says 29.5?
  • GatorGator Posts: 29Registered Users ✭✭
    Chk'd each batt with meter varied bit round 13.5,but 1 was 10.3...obviously not balanced... but day b4 watched tv with no apparent issues
  • GatorGator Posts: 29Registered Users ✭✭
    2 begin with im way outta my pay grade with all this solar stuff....lol
  • EstragonEstragon Posts: 2,219Registered Users ✭✭✭✭
    With the pv input breaker OFF, what is the voltage at the controller battery terminals?
    Off-grid.  
    Main daytime system ~4kw panels into 2xMNClassic150 370ah 48v bank 2xOutback 3548 inverter 120v + 240v autotransformer
    Night system ~1kw panels into 1xMNClassic150 700ah 12v bank morningstar 300w inverter
  • GatorGator Posts: 29Registered Users ✭✭
    With pv  input breaker off and batt. 2 controller breaker off..10.8 volts at batt. out-terminals
    So on controller info screen the 29.5 was feed from pv?
  • EstragonEstragon Posts: 2,219Registered Users ✭✭✭✭
    You want to read voltage at the battery terminals in the controller (battery + and common negative) with the pv input breaker open (off) and the battery breaker closed (on).

    To simplify things, you may want to disconnect the battery string with the 10.3v reading for now.
    Off-grid.  
    Main daytime system ~4kw panels into 2xMNClassic150 370ah 48v bank 2xOutback 3548 inverter 120v + 240v autotransformer
    Night system ~1kw panels into 1xMNClassic150 700ah 12v bank morningstar 300w inverter
  • GatorGator Posts: 29Registered Users ✭✭
    If i dis connect the 1 batt. That reads 10.3 volts, then i wont b series/parallel for 24 volts anymore...correct?
    There are 4, 12 volt ups batteries all 2gether, wired series/parallel...if i disconnect 1 then i'd have 18 volts?
    How does that work?
  • mcgivormcgivor Posts: 1,642Registered Users ✭✭✭✭
    R-Y-G led sequencing would either be a  DIP switch fault or a self-test fault. You mentioned controller screen so assumption would be you havea remote meter, if this is the case have you gone into the diagnosis  menu? 
      1500W, 6× Schutten 250W Poly panels , Schneider 150 60 CC, Schneider SW 2524 inverter, 8×T105 GC 24V nominal 

  • EstragonEstragon Posts: 2,219Registered Users ✭✭✭✭
    edited May 5 #19
    You have 2 strings of batteries. 2x 12v = 24v. One of those strings has a battery with a voltage of 10.3v. I'd take that string out to simplify troubleshooting. The parallel connection will be + to + and - to -. Lift a +to + connection and you break the parallel connection. Having taken the bad string out, you should be left with a + and - connection from the controller to the (24v) pair of good batteries.

    BTW, open the breaker to the controller when moving battery wires. Less sparky that way.
    Off-grid.  
    Main daytime system ~4kw panels into 2xMNClassic150 370ah 48v bank 2xOutback 3548 inverter 120v + 240v autotransformer
    Night system ~1kw panels into 1xMNClassic150 700ah 12v bank morningstar 300w inverter
  • mcgivormcgivor Posts: 1,642Registered Users ✭✭✭✭

    Here is a list of fault codes, attached pdf 
      1500W, 6× Schutten 250W Poly panels , Schneider 150 60 CC, Schneider SW 2524 inverter, 8×T105 GC 24V nominal 

  • BB.BB. Posts: 27,351Super Moderators admin
    What size, type, etc. Batteries are you using?

    10.3 volts is a dead 12 volt lead acid battery. And the longer it sits dead, the more likely it will never recover (it may already too late anyway).

    Normally, I would suggest you get all batteries quickly and fully charged before any of the rest go bad.

    It is possible that this battery has a shorted cell. Use a hydrometer to check the sg of each cell.

    Bill
    Near San Francisco California: 3.5kWatt Grid Tied Solar power system+small backup genset
Sign In or Register to comment.